Jacks_Depression

Jacks_Bad Air

Posted: 2010-05-22 07:02:06

I am a Ubuntu user, this is public information. I used 64 bit version of Ubuntu of course, as any serious Linux user does.

I also have had a Pandora account since 2006 and I'm a subscriber. As such I use the desktop based Pandora One on Adobe's Air framework.

While upgrading to the never version of Ubuntu (10.04) I came across this error when trying to install Pandora One in air:

dev@dev-desktop:~/Downloads$ sudo /opt/Adobe\ AIR/Versions/1.0/airappinstaller ./pandora_2_0_3.air
Error loading the runtime (libadobecertstore.so: cannot open shared object file: No such file or directory)

Long story short, you need to install Java. OpenJDk wont cut it.

This is a problem though, because Canonical decided to deprecate Java. Probably because it is not released under an open source license.

So just follow their instructions and it should work just fine...

Ubuntu Release 10.04, Java


Or my version:

sudo add-apt-repository "deb http://archive.canonical.com/ lucid partner"; sudo apt-get update; sudo apt-get purge openjdk-6-jre; sudo apt-get install sun-java6-jre

And it works just fine. Hope I helped.